Topic Unable to start up DataCleaner (any version ) on mac

Steve Robinson started the topic:
2015-02-16 15:44

Unable to start up DataCleaner (any version ) on mac

Hello,
When I attempt to start up DataCleaner, the icon appears in the dock for a second and then disappears. A few notes:
  • I am running the latest version of OSX, Yosemite, with all updates
  • I have "Anywhere" selected for "Allow apps downloaded from" in security settings
  • I have tried multiple versions of DataCleaner, including version 4 RC, all have the same result.
  • I have Java for OSX installed from apple, as well as the latest version of Java 8 runtime from Oracle
When I review the system log, this is the output I get when I try to run the app:

 2/16/15 9:37:18.895 AM Dock[231]: no information back from LS about running process LSASN:{hi=0x0;lo=0x5d05d}
2/16/15 9:37:19.270 AM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.oneshot.0x1000000d.JavaApplicationStub_64bit[490]) Service exited with abnormal code: 1

Anyone have any ideas?

Thank you so much in advance,

Steve
Kasper Sørensen replied:
2015-02-16 17:59
Hi Steve,

Thank you for the detailed issue report. I hope I can help you...
Can you tell me if DataCleaner generated a logs directory within it's base directory?
If so, can you check "datacleaner.log" file?
If not, how about your user-home, does it contain a ".datacleaner" directory?

Kasper
Steve Robinson replied:
2015-02-16 18:59
Hi Kasper,
Thank you for the quick response.

DataCleaner does not appear to have generated a logs directory, though I have to say that I'm not entirely clear on what the base directory is on a mac. How Java apps work on a mac is a bit of a mystery to me. I'm assuming it is a subdirectory of the DataCleaner.app directory, in which case I can authoritatively say DataCleaner did not create a logs directory anywhere inside of there.

I checked my user's home directory and it does not contain a .datacleaner directory.

Is there another way I can create a log/output for you? Can I attempt to execute a jar file from the command line?

Thank you,

Steve

Kasper Sørensen replied:
2015-02-16 19:10
Hi Steve,

Yes, try with the command line is a good idea...

Go to the "base directory" which is the directory that contains datacleaner.jar and then invoke:

java -jar datacleaner.jar

Kasper
Steve Robinson replied:
2015-02-16 19:20
Hi Kasper,

I don't have a datacleaner.jar file. The closest thing I have is:

{{/Applications/DataCleaner.app/Contents/Resources/Java/repo/com/hi/common/common-datacleaner/1.0.1/common-datacleaner-1.0.1.jar}}

I've confirmed that datacleaner.jar is not in the zip file I downloaded, either.

When I attempt to run that file, this is what I get:
Steves-MBP:1.0.1 steverobinson$ java -jar common-datacleaner-1.0.1.jar 
Failed to load Main-Class manifest attribute from
common-datacleaner-1.0.1.jar

Am I missing something?

Steve
Kasper Sørensen replied:
2015-02-16 19:24
Hmm I am such a Mac newbie, don't know really how those .app files work after all :-|

Maybe you can try downloading the platform-independent version... That for sure has the normal structure and jar files (and .sh file if you want it)...
Steve Robinson replied:
2015-02-16 19:39
Hi Kasper,
I have an error for you! Hopefully we can figure out what this means:

Feb 16 13:35:52 Steves-MBP.local java[1071] <Error>: The function ‘CGContextErase’ is obsolete and will be removed in an upcoming update. Unfortunately, this application, or a library it uses, is using this obsolete function, and is thereby contributing to an overall degradation of system performance.
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eobjects/datacleaner/Main : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

When I issue a java -version at the console, this is what I get:
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

Any thoughts?
Kasper Sørensen replied:
2015-02-16 19:41
That looks an awful lot like you have Java 6 runnin. DataCleaner requires java 7 or 8.
Steve Robinson replied:
2015-02-16 19:48
Duh. Sorry, I had uninstalled and reinstalled java 8 several times and apparently left it in an uninstalled state.

I reinstalled Java 8 and the universal app works fine, but the Mac app still fails with the same error codes.

I didn't even realize the universal one existed, so with your help, I'm good to go running with the universal app. THANK YOU, KASPER!!!

I wish I knew enough about Java and OSX App bundles to help diagnose the issue with the native OSX version. If I can be of any assistance to anyone troubleshooting this, let me know. I'm happy to provide any additional information if there are others reporting the same issue and you need help getting past it.

Steve

Kasper Sørensen replied:
2015-02-16 19:51
Glad that it works :-)
Honestly we need to add more focus on the Mac version. I'll try and make sure that we put it on the radar for the 4.0 release! You're not the first who had issues. Might ask you to test it if we make improvements :)
You are not signed in.
You need to be signed in to participate in the discussion.